
Remote Sensing 4113
Lab 11 alternate:  Vegetation

April 18, 2018

Part I  Introduction

The lab instructions consist of three parts:  1)  an introduction/background section, 2)  a set of 
specific instructions regarding data to analyze and results to obtain, and 3)  an explanation of the 
ENVI instructions needed to carry out the work in section 2.  As in past computer labs, create a 
lab_11 directory on your local machine in your personal directory.  Download from the class 
website and unzip the lab_11_data file.  When finished mail your report to the TA.

A variety of indexes and transformations are used for recognizing and characterizing vegetation.  
As discussed in class, two common indexes are the simple ratio, SR = Near-IR / Red, and the 
Normalized Difference Vegetation Index, NDVI = (NIR-Red)/(NIR+Red).  A more complicated 
transformation using Landsat Bands 1,2,3,4,5,7 is called the Tasseled Cap because a resulting 
scatter plot of two output parameters (“Greenness” vs. “Brightness”) resembles such a hat.  All 
these indexes rely heavily on the fact that vegetation is highly reflective in the Near IR but dark 
in the Red band.  To a greater or lesser extent they try to remove confusion which could be 
caused by non-vegetation differences.

This lab will explore producing SR, NDVI, and Tasseled Cap indexes from a Laramie Valley 
Landsat image.

For reference a reflection spectrum of vegetation, and a list of the Landsat TM bands, is included 
below.

  TM Band # Wavelengths 
(μm)
     1   0.45 – 0.52

    2   0.52 – 0.60
    3   0.63 – 0.69
    4   0.76 – 0.90
    5   1.55 – 1.75
    7   2.08 – 2.35

    6  10.40 – 12.50
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Part II:  Specific Lab Instructions

We will use the Landsat TM image of the Laramie Valley obtained 17 June 1991, which we 
also used in an earlier lab.  (Use the version in the lab_11 folder.  This version has the 
unneeded TIR band 6 removed.  Its presence (in for example the Lab 4 data) causes some 
problems with the ENVI routines used here.)  This time we will use the ENVI calibration 
routines to convert the raw (0-255) TM data numbers to reflectance, then will compute 
various vegetation indexes and related transformations, and will examine the results.

1) ENVI will need the solar elevation angle (the angle of the sun above the horizon) in 
order to determine how much incoming solar radiation there is, so it can calculate 
calibrated reflectance values.  To find an approximate value we can use the Solar 
Position Calculator at <http://www.srrb.noaa.gov/highlights/sunrise/azel.html>.  Open a 
web browser and enter that URL. On that web page under “City” tell it you want to 
specify the latitude and longitude (since Laramie isn't in its list) then enter (105o36' W,  
41o25' N).  Tell it that the offset between local time and UTC (Greenwich Mean Time) is 
7 hours, and tell it NOT to use daylight savings time since the value we will enter will be 
in standard time. Finally, enter the above date of the observations and enter the 
approximate local time (9:30 AM Standard Time) when Landsat passes over our latitude. 
Click Calculate_Solar_Position then write in your lab report the Solar Elevation and 
Solar Azimuth. Discuss in a sentence or two whether those values are reasonable.

2) See the note below if you have problems with this step.  Using the main ENVI menu 
open the Laramie Landsat TM file, and as described in the computer instructions, convert 
the raw data to Reflectance (not radiance).  Save the results to an ENVI format image file 
so you can read it back if needed.  The data should also appear in the available Band List 
window.

A bug was introduced in ENVI 4.6.1 which was fixed for a while but as of now 
(2018) is back again.  It prevents ENVI from calibrated the “raw” or 
“uncalibrated” TM data file.  Try to calibrated it so you’ll know how the procedure 
SHOULD work but if you receive an error message, for the following steps open the 
“calibrated” file provided, which I produced with an earlier version of ENVI.  That 
calibrated file is the one with _cal in the name.

3) Load bands 432 (NIR-Red-Green) of the just calibrated image as RGB.  Save a jpg copy 
of the image for inclusion in your report.  From the Image menu select Tools->Cursor 
Location/Value to open a window which lists those quantities.  Move around the image 
and determine typical  values for the NIR, Red, and Green reflectances in several 
different types of terrain (at least the following:  Water, Thick Vegetation, Plains, and 
Urban Areas).  Write those in your report and discuss briefly whether the numbers you 
are obtaining seem reasonable for reflectances.   (Note – you will probably want to use 
the scroll and main image windows to move around, then read values while the cursor is 
in the zoom window.)
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4) Create a 2-D scatter plot (see the computer instructions) with the calibrated TM3 (Red) 
band on the X axis and the calibrated TM4 (NIR) band on the Y axis.  That scatter plot 
should look roughly like the following tilted “Tasseled Hat” figure.  Use the color 
highlighting / classifying techniques described in the computer instructions for scatter 
plots to divide the “tasseled hat” into 6 colored coded regions:  high biomass, 
intermediate biomass, low biomass, wet bare soil, moist bare soil, and dry bare soil.  
When you color a region of the scatter plot the corresponding pixels in the main image 
window will also be colored.  Try this a few times to get an “optimum” choice of regions 

which separate out the 
different levels of 
biomass and different 
amounts of moisture in 
the image.  Save copies 
of both the color coded 
scatter plot and the 
color coded image for 
inclusion in your report. 
(So that you can see the 
different classes in the 
image you will 
probably just want to 
save an image of the 
Laramie area and the 
nearby rivers and 
meadows, rather than 
the entire scene.  See 
the “Saving as an Image 

File ...” computer instructions on how to do this.)  Discuss in a few sentences how well 
the classification has worked in terms of recognizing the different regions.

5) Using Band Ratios (see computer instructions) create a “Simple Ratio” (SR, also 
sometimes called a Ratio Vegetation Index) of Band 4 / Band 3 and save it to a file.  
Load this as gray-scale into a second display and record typical values for the Ratio both 
in thick vegetation and in the other areas.  Save as a jpg file the same portion of this that 
you saved in part 4, for inclusion in your report.  

Create an NDVI index map using the computer instructions at the end.  (You could use 
band math to do this but ENVI has a built in function.)  Load this as gray-scale into a 
third display and record typical values both in thick vegetation and in the other areas. 
Save as a jpg file the same portion of this that you saved in parts 4 and 5.  Compare the 
images from parts 4, 5, and 6 and discuss in a few sentences how well the SR and NDVI 
indexes recognize the regions of vegetation.  Measure and record the value of the SR and 
the NDVI in the different types of terrain discussed above.
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We can empirically determine the relative calibration of the SR and the NDVI curves 
shown below from Jensen Figure 11-21 by creating a 2-D scatter plot with our SR curve 
as the X axis and our NDVI curve as the Y axis.  Produce that plot.  From the scatter 
plots menu use Options -> Set X/Y axes ranges to adjust the axis to be the same as in 
Figure 11-21.  Save the plot for inclusion in your report. Note we have to get the same 
result if we've done the calculation correctly since

NDVI = (B4-B3)/(B4+B3) = (B4/B3 – 1) / (B4/B3 + 1) = (SR – 1) / (SR + 1)   .

Does your curve in fact match that shown below? 
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6) ENVI also contains routines to calculate the “Tasseled Cap” transformation.  As 
described in the computer instructions, this transforms our calibrated data to create the 
“Brightness”, “Greenness”, and “Third” channels.  The “Third” channel is related to 
wetness and soil type.  Load the “Greenness” channel into a (4th) gray-scale display, save 
a copy for inclusion in your report, and compare the resulting image to the SR and NDVI 
ones.  Next, load all three bands into your 4th display, with (Third, Greenness, 
Brightness) = (RGB).  Save a jpg image for inclusion in your report.  Finally, from the 
image's menu select Tools -> 2D Scatter Plot, and create a scatter plot with 
Brightness on the X axis and Greenness on the Y axis.  Save a copy for inclusion in 
your report.  You should obtain a plot very similar to that from Part 4, except it has now 
been rotated so the “bare ground” line is more-or-less horizontal while the increasing 
biomass line is more-or-less vertical.  (In reality the tasseled cap is still slightly rotated – 
probably because of some inaccuracies in the calibration of our reflectances.)  When 
calibrated and rotated properly we could use the Y (“Greenness”) Axis as a direct 
measure of biomass.  As described in the lecture, we could also use such a plot to follow 
the changes in a crop throughout the growing season.

Summary:  Your report should contain:

1. The solar elevation and azimuth for the observations, and a brief discussion of whether 
your values are reasonable.

2. A (NIR, Red, Green) color-infrared version of the calibrated image (for reference) and 
also a table giving the NIR, Red, and Green reflectances in several types of terrain.  You 
should also discuss whether those values are reasonable.

3. A 2-D scatter plot of NIR vs. Red, color coded into at least 6 different regions, 
accompanied by the color coded version of the image.  You should also discuss how well 
the scatter plot properly classifies the different types of terrain.

4. The SR and NDVI images, typical values for these indexes in the different types of 
terrain, and a discussion of how well these images measure vegetation.

5. The NDVI vs. SR calibration curve produced by a scatter plot.

6. The Tasseled Cap Greenness image (shown as gray-scale) and a comparison with the 
above vegetation results.  The color image using all three tasseled cap bands, and the 
scatter plot of Greenness vs. Brightness
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Part III:  Computer Procedures

Procedure for Calibration:

From the main ENVI menu select Basic Tools->Preprocessing->Calibration Utilities-
>Landsat TM

then in the Input File window select the Laramie TM data file.  Use the defaults for the other 
choices: Spatial Subset = Full Scene and Spectral Subset = 6 out of 6 bands and click OK.
In the TM Calibration Parameters window which will appear next, select Landsat 5, specify the 
date information (June 17, 1991) and the solar elevation.  Select Reflectance (not Radiance).  
Choose an output file name in your lab_13 directory, then click OK.

2-D Scatter Plots

From an image window menu select Tools->2-D Scatter Plot.  In the Scatter Plot Band 
Choice window which appears, chose the bands to plot as X and Y.  After the plot window is 
opened you can save a copy of it (as a jpg image) using that window's menu:  
File->Save_plot_as. 
You can also find which regions of the scatter plot correspond to which regions of the image. 
To define a polygonal region of the scatter plot to investigate, click the left mouse button on the 
corners of the polygon you want to highlight.  After defining all the corners click the right mouse 
button to close the polygon and “color” both the pixels in the scatter plot and the corresponding 
pixels in the image.  To select the colors to use, from the scatter plot menu select 
Class->Items 1:20 then pick a color.  To clear the colors from the scatter plot menu select 
Option->Clear All.  Be careful not to move the selection box in your image scroll window or 
the colors will also be cleared.

Saving as an Image File Just Part of the Scene

To save a copy of just the main image to the window you can use the procedure in the next 
paragraph, or as a shortcut, you can press the Alt and the Print Screen keys to copy the 
currently active window to the clipboard (Alt+F14 on the Mac keyboards), then just paste that 
image into your report.  When you want to save the image with the overlay colors created by 
mapping ROI's in a 2-D scatter plot, this window copy is simplest, as the procedure outlined 
below does not save overlay colors.

When you ask ENVI to save an image (usually in jpg format) it typically saves the full image, as 
shown in the scroll window.  If you want to save just that portion in the main image display 
window, after selecting 
File->Save Image As->Image File in the Output Display to Image File window click 
Spatial Subset to override the Full Scene default.  In the Select Spatial Subset window 
which will appear, click the Image button.  It will bring up a small image display with the current 
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“main image window” area outlined in a red box.  Just click OK to accept that subscene, or drag 
the box or its corners to adjust the part of the scene to save.

Band Ratios

To compute band ratios (we did this in an early lab) from the main ENVI menu select
Transform->Band Ratios then in the Band Ratio Input Bands window which will appear 
select the bands to use as the numerator and denominator, and click Enter Pair.  In the Band 
Ratios Parameters window which will appear accept the default Spatial Subset = Full 
Scene, choose an output file name in your own directory, and click OK.

NDVI Calculation

To calculate the NDVI for an image from the main ENVI menu select
Transform-> NDVI then in the NDVI Calculation Input File window which will appear 
select the calibrated image, accept the default Spatial Subset = Full Scene, and click OK.  In 
the NDVI Calculation Parameters window which will appear, accept what should be the 
default Input File Type = Landsat TM, and the NDVI bands Red=3, NIR = 4 (or change them 
if these are wrong), choose an output file in your directory, accept the default Output Data 
Type = Floating Point, and click OK.

Tasseled Cap Transformation

For Landsat TM data this transforms the six visible through SWIR bands into three bands labeled 
“Brightness”, “Greenness”, and “Third”.  Other variants are available for Landsat MSS or ETM 
data.  From the main ENVI menu select Transform -> Tasseled Cap then in the Tasseled 
Cap Transform Input File window which appears select the calibrated Laramie data, select 
the default Spatial Subset = Full Scene, and click OK .  Click Input File Type and select 
Landsat 5 TM then chose an output file in your own directory.

Comparing two different images

To compare images you can also load your classification results as a Gray Scale image on a 
New Display – then use the Tools->Link->Link Displays menu of that new display to link it 
to the original color-infrared image, or to another classification image.  Holding down the left 
mouse button within one image causes the other one to momentarily appear.  
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