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April 11, 2018

Part I  Introduction

In this lab we’ll explore the use of sophisticated band math to estimate composition, and we’ll 
also explore the use of a decision tree classification scheme.  We'll be using data from the 
UV-Visible sensor on the Clementine mission which orbited the moon in the 1990's.  The band 
math will be used to estimate the Ti abundance in the mare basalts.  Once that is done the 
decision tree will be used to classify the lunar surface into three types:  highlands, low-titanium 
mare basalts, and high-titanium mare basalts.

The lab instructions consist of three parts:  1)  an introduction/background section, 2)  a set of 
specific instructions regarding data to analyze and results to obtain, and 3)  an more general 
explanation of the ENVI instructions needed to carry out the work in section 2.  As usual, copy 
the lab_10 data files from the class website and unzip them to a temporary directory within c:\
tmp on your local machine.   Save any files you want to keep on your Home Drive.

The moon's surface is contains two very different types of terrain, the “highlands”, and “maria”.  
The highlands are the anorthosite crust which floated to the top of the original global magma 
ocean when the moon formed approximately 4.5 billion years ago.  Anorthosite has relatively 
high albedo.  The maria (the singular is mare) are basalts which erupted from the interior 
between approximately 3.0 to 3.5 billion years ago.  They have a range of compositions, with 
different iron (Fe) and titanium (Ti) compositions.  Increased Ti has the most obvious effect on 
the spectra.  The common mineral it occurs in (ilmenite) is dark, so it lowers the albedo of the 
maria.  However a more reliable test is that it is dark at all wavelengths, while Fe and some other 
variable components tend to be not just dark, but “red” -- with relatively high albedo in the red 
and low albedo in the blue.  Therefore the Ti rich mare appear dark but blue (relative to the Ti 
poor regions).  The amount of Ti can be estimated by comparing the brightness in the 0.415μm 
and 0.750μm bands, and using a mathematical transformation described below, similar in 
principle to that described in class to estimate Fe abundance.  

We'll examine the Clementine images of the moon, apply the mathematical transformation to 
obtain the percent Ti, then classify the surface based on albedo and Ti abundance.  For the 
purposes of this exercise we'll call surface with albedo greater than 0.15 (at 0.750 μm) 
“Highlands” and surface with albedo less than that “Maria”. We'll call maria with weight % TiO2 

less than  6% “Low Titanium Maria” and those with Ti greater than 6% “High Titanium Maria”.  
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The following section explains the calculation of Ti abundance, which you'll produce in part 2.   
It is based on Lucey et al.  (2000)  “ Lunar iron and titanium abundance algorithms based on 
final processing of Clementine ultraviolet-images”, J. Geophys. Res.  105:  20,297-20,305.  Both 
of the following figures are taken from there.

For a number of sites, either of Apollo missions or Russian unmanned “Luna” sample return 
missions, we have samples with measured titanium abundances, and we also have measured 
reflectances.  In the above Plot A we plot the ratio of the 415-nm / 750-nm reflectance, vs. the 
750-nm reflectance.  The first is a measure of “blueness” – which in general is greater for Ti-rich 
basalts, but as shown in the plot the amount of “blueness” for a given Ti abundance also depends 
on the overall albedo or reflectance.  The points which fall along the penciled lines have more-
or-less constant Ti abundances.  The Ti abundance increases with the angle θTi  as shown in Plot 
B.  We first need to calculate the angle θTi.   The lines above are drawn relative to an origin at 
(0.0, 0.42) so the formula for  θTi  is 

 θTi = Arctan [   (R0.415μm/R0.750μm) – 0.42) / (R0.750μm – 0.0) ]

To convert this θTi  to a titanium abundance, expressed (following geological convention) as 
weight percent of TiO2, we use the following formula which represents the curve fit to the data 
in Plot B.

% Weight TiO2 = 3.708 × ( θTi)5.975
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Clementine notes:

The UV-VIS sensor had 5 bands:

Name                   Band Center (    m)          Band Width (    m)  
Band 1 (A) 0.415 0.040 
Band 2 (B) 0.750 0.010
Band 3 (C) 0.900 0.020
Band 4 (D) 0.950 0.030
Band 5 (E) 1.000 0.030

The image file is a mosaic assembled from multiple individual images.  In places you can see the 
boundaries between the images.  The images were all obtained at times that were near local 
noon, so regions along the equator do not show significant shadows.  Only variations in albedo 
are apparent.  At higher latitudes some shadows are usually visible.  

The following map of the moon's near side can be used for locating major features.  The 
Clementine image shows both sides of the moon, with the near side centered in the image.  In 
recognizing features, Mare Imbrium is a good place to start.  The craters Copernicus and Tycho 
also make good landmarks because they are young, bright, and have large “ray systems” 
extending out from them.
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Part II:  Specific Lab Instructions

1) Download (from the class website) and unzip the lab_10 data file into your own lab_10 
subdirectory within C:/temp.    You should find a clementine_uvvis_5km_env data file 
and the corresponding clementine_uvvis_5km_env.hdr header file.

2) Read the Clementine image into ENVI, and create a Display 1 showing as (R,G,B) 
bands 5, 2, and 1.  Identify on the image the major near-side Mare such as Mare 
Imbrium, Mare Serenitatis, and Mare Tranquillitatis.  Experiment with different image 
“stretches” to see if you can identify by eye where you expect the maria to be Ti rich or 
poor.  The Ti rich sections should be both darker and more blue (at least compared to the 
rest of the mare).  The automatic stretch routines tend to be confused by the many 
regions with bad (or empty) pixels.  The best results seem to come from positioning the 
“zoom box outline” in the main image window over an interesting section of mare, then 
using Enhance-> Zoom: Gaussian to set the stretch.  The following image shows a 
portion of Mare Imbrium with a good stretch.  (Unfortunately the print will probably 
only show a small fraction of the detail visible on-screen.)

Once you have a stretch which shows good detail, save a jpg copy of the image for 
inclusion in your report.  (This should be a version of the full moon image – which 
should be the default image saved.)

Places that show “interesting” Ti abundances are Mare Tranquillitatis, the inner vs. the 
outer parts of Mare Serenitatis, and also Mare Imbrium.  (See the map for these 
locations.)  Note the patterns you see for comparison with the Ti map we'll obtain later.
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3) Using Basic Tools -> Band Math calculate the θTi  parameter.  Note that you will enter 
the formula as follows:
 atan( ((B1/B2)-0.42) / (B2 – 0.0) )

You'll need to tell the system that B1 corresponds to Band 1 and B2 corresponds to 
Band 2.  
Save the result to a file theta_ti.env in your own directory.  Examine the resulting 
image to make sure it does show higher theta values where (based on step 2) you expect 
to see more titanium. You may want to “link” the two displays together, as described in 
the computer instructions.  When you're done you can close the θTi  display.

4) Using Basic Tools -> Band Math convert the above θTi  parameter into Weight % TiO2 

using the following formula
 3.708 * (B6^5.975) .
You'll need to tell the system that B6 corresponds to the θTi  “band” you created.  Save the 
result to a file ti_abundance.env.  Display the result and again compare it to your 
previous images.  Once again the automatic stretch routine tends to get confused.  
Enhance->Scroll: Gaussian seems to do a better job.  Be sure you really do have high 
Ti values where you expect them.  Save a copy of the image as jpg for inclusion in your 
report.  Describe in a few sentences what patterns of Ti abundance you see in 
Mare Tranquillitatis, Serenitatis, and Imbrium.

5) Use the Tools->Cursor Location/Value on the Image menu to display pixel values. 
Find typical values for both the Band 2 (0.750μm) reflectance and the Ti abundance for 
the following three locations – and put that information in your report.

Typical Albedo Typical Ti Abundance

Highlands: ____________ __________________

Low Ti Maria ____________ __________________

High Ti Maria ____________ __________________
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6) Create a classification image for the lunar maria using Classification->Decision 
Tree->Build New Decision Tree from the main ENVI menu.  It will open a window like the 
one below.  Click on Node 1 in it and another window will open.  Enter the expression B2 gt 
0.15, which will test whether the Band 2 (0.750 μm) reflectance is greater than 0.15, to 
determine whether a pixel is highland or maria.  ENVI will next open up an Variables / File 
Pairings window.  As in band math you have to tell the system which Bnn corresponds to which 
band.  Click on {b2} and another window will open which will let you select the original image's 
Band 2 (0.750 um) then click OK.    Next click on Class 1 and when ENVI opens a new 
window, rename this class highlands.

We now need to add a second-level branch to distinguish between high and low Ti maria. 
Right click on Class 0 and select Add Children.  A new decision box will appear in place of 
Class 0.  Click on it and enter the expression B7 gt 6.  In the Variables / File Pairings 
box assign B7 to TI Abundance.  Click on Class 2 and rename it Low Ti Maria, and click on 
Class 3 and rename it High Ti Maria.

You should now have a decision tree which looks like the following.

In its menu click Options->Execute then in the window which will open specify 
lunar_class.env as the name of the file where the results will be saved.  The system will 
classify all the pixels then open up a display showing the result.  Link that display to your other 
(RGB and Ti Abundance) displays and check to see if the classification is reasonable.   

In a few sentences describe how well the classification matches what you expected, in 
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particularly in Mare Tranquillitatis, Serenitatis, and Imbrium.  How well does it distinguish the 
high and low titanium basalts?  What patterns do you see within the overall mare basins?  
Finally, either add a graphical classification key overlay (as we did in an earlier lab) or just say 
in the text of your report which colors correspond to the three terrain types.

Summary:  Your report should contain:

1. A copy of the RGB (=Band 5,2,1) image of the moon, showing variations in the color and 
albedo of the mare lava as well as the overall mare / highland difference.

2. A copy of your Ti Abundance Image, along with a brief description of whether the Ti 
abundance followed your expectations based on the B1/B2 ratio.  You should also 
include a few sentence description of the Ti abundance patterns seen in Mare 
Tranquillitatis, Serenitatis, and Imbrium.

3. Your table giving typical albedo and Ti abundances for the three terrain types.

4. Your classification map plus a key or text showing the location of the three terrain types.  
You should also discuss how well the classification has recognized the patterns in 
Tranquillitatis, Serenitatis, and Imbrium.  In particular, how well does it distinguish the 
high and low titanium basalts and what patterns do you see within the overall mare 
basins?
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Part III:  Computer Procedures

Procedure for Band Math:

From the main ENVI menu select Basic Tools->Band Math.  A Band Math window will 
appear.  Enter the formula you want to use, for example

B1/B2
in the middle part of the window then click Add to List. ( Note:  You use operands of the form 
Bnn where nn is a one or two digit number, then in a later step tell ENVI which bands are 
associated with Bnn.)  That formula will appear in the top pane of the window, along with any 
previous ones you've entered.  Select the one you want to use in that top pane, then click OK.

At this point a Variables to Band Pairings window will appear.  In an upper pane select the 
Bnn you want to define and in the middle window select which band should correspond to it.  
Repeat this till all the Bnn are defined. You may need to use the up-arrow and down-arrow keys 
in the upper pane to see all the different Bnn.

For all our tests use the default Spatial Subset: Full Scene setting, to output the full image.

In the bottom part of the window select whether you want to output the result to memory (for 
temporary use) or to a file.  In most cases we'll want file output.  If so, click Choose and select a 
file name located  in your directory.

When all the above information is completed click OK, the operation will be performed, and the 
result will appear in the Available Bands window.

You can then use the buttons at the bottom of the Available Bands window to either show it in 
an existing display, or create a new display for it.

Saving as an Image File Just Part of the Scene

To save a copy of just the main image to the window you can use the procedure in the next 
paragraph, or as a shortcut, you can press the Alt and the Print Screen keys to copy the 
currently active window to the clipboard, then just paste that image into your report.  (On the 
Mac keyboards the equivalent key combination is Alt+F14.)

When you ask ENVI to save an image (usually in jpg format) it typically saves the full image, as 
shown in the scroll window.  If you want to save just that portion in the main image display 
window, after selecting 
File->Save Image As->Image File in the Output Display to Image File window click 
Spatial Subset to override the Full Scene default.  In the Select Spatial Subset window 
which will appear, click the Image button.  It will bring up a small image display with the current 
“main image window” area outlined in a red box.  Just click OK to accept that subscene, or drag 
the box or its corners to adjust the part of the scene to save.
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Comparing two different images

To compare images you can also load your classification results as a Gray Scale image on a 
New Display – then use the Tools->Link->Link Displays menu of that new display to link it 
to the original color-infrared image, or to another classification image.  Holding down the left 
mouse button within one image causes the other one to momentarily appear.  
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