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In this lab we will explore Spectral Unmixing techniques.  Rather than simply trying to classify 
different pixels, these techniques attempt to estimate the amount of different minerals present in 
a given pixel.  The first step in Spectral Unmixing is to determine the spectra of the 
“Endmembers” – those components which when averaged together in the right amount can 
produce all the observed spectra.  We will explore two techniques for obtaining endmembers.  
With the first we will select certain Regions of Interest (ROIs) in the image which we hope are 
composed of “pure” endmembers, and then use the spectra of those pixels.  Finding the right 
endmembers is usually a time consuming process so for this lab I have preselected certain 
regions.  With the second technique we will importing mineral spectra from the USGS spectral 
library.

For convenience we will again use the Como Bluff Aster data.  However be aware that the 9 
visible through short-wavelength IR bands available are not really enough for detailed unmixing 
modeling.  Much better results would be obtained with hyperspectral data.

Because we will be comparing the observations to laboratory spectra we need true reflectivity 
data.  I've produced a more-or-less calibrated reflectance version of the data for use this week.  
Be sure to use that file rather than the raw DN data from last week.  The calibrated version was 
obtained by applying ASTER sensitivity information to obtain radiance at the sensor, then 
dividing that result by the expected spectrum of the sun.  This data has not yet been corrected for 
atmospheric transparency, so the values for some filters (in particular Band 9) will be slightly too 
low.

As usual, use a temporary directory within c:\tmp on your local machine for all your files, and 
copy the lab_09 data zip file from the class website to your local machine and unzip it.  You 
should see the following files:  the aster_como_bluff_reflectance image and hdr files and 
the como_bluff_predefined.roi file.  Save any files you want to keep on your Home Drive.  

Part I: Spectral Linear Unmixing using ROIs

I have selected eight “Regions of Interest” (ROIs) in the Como Bluff image.  We will find the 
spectra of those regions then attempt to model the rest of the image assuming the other pixels are 
a linear mixture of those eight types.     

1. Defining Regions of Interest (ROIs)
Open the Como Bluffs image  (File->Open Image File), and load Bands 3,2, 1 as 
RGB. Click on the image's Maximize button (on the title bar) to make the image large 
enough that the Scroll window disappears.  Save a copy for inclusion in your report.

To see how to define a ROI, from the Image window menu select 
Tools->Regions of Interest->ROI Tool....  A ROI Tool window will appear, and 
a Region #1 will appear in the list of ROIs.  Initially it should contain 0 pixels.  Near the 
top of the window there will be a set of “radio buttons” which let you select whether to 
draw the ROI in the Image, Scroll, or Zoom window, or turn the tool off to use the cursor 
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for other tasks.  Select Zoom if it is not already selected.  From the ROI Tool's menu 
select ROI_Type and be sure that Polygon is checked.  (The other options are polyline 
and point.)  Drag the red zoom box in the main image to an interesting area.  Left-click 
the mouse in the Zoom window to define the corners of a polygon which outlines a region 
of interest.  (You may want to enlarge the zoom window.)  When finished selecting 
corners, right-click the mouse to close the polygon.  A small diamond will appear in the 
polygon.  You can drag with the left mouse button to move the polygon. When it is 
located correctly, right-click the mouse again.  The ROI will then be filled with a 
preselected color and the total number of pixels will be indicated in the ROI Tool 
window. You could then click on the name there to change it to something meaningful, 
and you could also change the color.  You would normally select ROIs for all the 
different Endmember components you would use in the modeling.  Because that is a time 
consuming process we'll start by using ROI's that have already been defined, and will 
delete the ROI you just created after reading in those predefined ones.

2. Reading predefined ROIs.
In the ROI Tool menu select File->Restore ROIs... and in the file selection box 
which opens select como_bluff_predefined.roi then click OK.  Click OK again on the 
confirmation box which will open.  The ROIs should now appear in the ROI tool 
window.    Go to that window, click on the Region #1 entry to select it,  then click on the 
Delete button to remove it.

To see where the ROIs are located select each one in the ROI Tool window list then click 
Goto.  The red zoom box will jump to the ROI.  If a ROI consists of more than one 
polygon, each time you click Goto it jumps to the next polygon.

3. Computing average spectra and statistics for the ROIs.
Select all the ROIs with the Select All button in the ROI Tool window,  then click the 
Stats button.  A ROI Statistics window will open showing the average ROI spectra 
and various statistical information.  By holding the left mouse down in the plot window 
you can examine the numerical values for each of the spectra.  You should be able to 
recognize at least the vegetation spectrum.  The differences between the others will be 
subtle, suggesting that we may not be able to completely unmix the spectra given the 
limited data available.

4. Applying Spectral Linear Unmixing.
From the main ENVI window select 
Spectral->Mapping Methods->Linear Spectral Unmixing.  A window will open to 
select the input file.  Select  the aster_como_bluffs_reflectance file and click OK.  
Next an Endmember Collection window will appear.  From its menu select 
Import->From ROI/EVF from input file.  Another window titled Select Regions 
for Stats Calculation will appear listing all the predefined ROIs.  Click the 
Select All Items then click OK.  The spectra of the ROIs will finally be entered into 
the Endmember Collection window.  Clicking Plot will display those spectra in a new 
window.  On the Plot Window menu select Options->Plot Key to add the key.  
Enlarge the window to a reasonable size and save it for inclusion in your report.     To 
perform the unmixing, in the Endmember Collection window click the Apply button.  
An Unmixing Parameters window will appear.  For now leave the “Apply a unit sum 
constraint” at the default NO.  Choose an output file name in your directory then click 
OK.  After calculations are finished a set of new entries should appear in your Available 
Bands List, one for each component plus an RMS error image.
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Load the Vegetation component in a new display window by right clicking on that entry 
in the band list then selecting Load band to new display in the pop-up menu.  (This is 
a short cut for the longer steps of opening then loading a new window.)  Maximize that 
new image window to make the Scroll window disappear then use Tools->Link 
commands to link this window to your original display.  Pressing the left mouse button in 
the new image window will temporarily show the linked image, allowing easy 
comparison.  How well did the unmixing select the vegetation?  To determine this 
quantitatively use Tools->Cursor Location/Value to open a window displaying this.  
What are typical minimum and maximum values for Disp #2 data – the fraction of the 
pixel thought to be occupied by vegetation?  Record this range, and save a copy of the 
image for inclusion in your report.

Successively examine the other component images and save copies for your report.  You 
can just load them to the current (#2) display.  The short cut to load them in this Display 
#2 is to right-click on them in the Available Band List then select 
Load band to current display. Examine the typical fraction occupied numbers.  
Discuss in a few sentences how well the unmixing worked.  For some components it will 
work well but for other ones it fails badly.  Besides providing a poor match, some 
components will show fractions less than zero or greater than one.  Most likely we are 
missing some endmember spectra, and we also have noise present in our data.  In 
addition, microscopic mixing is inherently non-linear, so it cannot be modeled with these 
simple techniques.  You don't need to discuss each component in detail.  But do report a 
couple of the best and the worst fraction numbers for each.  

5. Matched Filtering.
A more sophisticated variant of Spectral Linear Unmixing is Matched Filtering.  As 
described in the ENVI User Guide, when you have unknown endmembers “This 
technique maximizes the response of the known endmember and suppresses the response 
of the composite unknown background, thus matching the known signature.”
In the Endmember Collection window menu select Algorithm->Matched Filtering 
then click Apply.  In the window which opens select a name for the statistics and the 
output image files in your own directory, then click OK.  After calculations are finished a 
series of MF score bands will appear in your band list.  Once again, selectively load these 
into   Display     #2  , save them to your report, and comment on the quality of the match and   
also the range of the data values.  For example for the Vegetation band, what values do 
you obtain over vegetation, and what do you obtain over bare regions? 

Part II: Resampling and Convolution of Laboratory Spectra

6. Restart ENVI.
To be sure ENVI is in a well defined state, exit it, restart it, then reload the Como Bluff 
image with Band #3, 2, 1 as RGB, and again maximize the main image window.

7. Obtaining USGS Laboratory Spectra.
 Many laboratory spectra in libraries were obtained at much higher resolution than can be 
expected in remote sensing data.  In using the laboratory spectra we often need to 
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“convolve” or average the spectra over the relatively broad filters in which our remote 
observations are obtained.  We may also need to interpolate the laboratory data to match 
wavelengths.  ENVI calls this process resampling.  It knows how to do much of this 
automatically, but in this Part II we'll following a slightly indirect procedure so we can 
see those convolution steps.

To use a Spectral Library (an sli file) we first need to open it so it appears in the 
Available Bands List.  From the main ENVI window select 
Spectral->Spectral Libraries->Spectral Library Viewer.  In the 
Spectral Library Input File window which appears, at the bottom click the Open> 
button, then select Spectral Library... .  A file selection box will open.  You should 
be positioned in the ENVI spec_lib directory.  Select the usgs_min subdirectory.  Select 
the usgs_min.sli file and click OK.   You may need to click OK in the previous window 
which now reappears.  USGS Mineral Spectral Library should now appear in the 
Available Bands List. 

A Spectral Library Viewer window listing many minerals should now appear.  (If it 
doesn't, from the main ENVI window again select 
Spectral->Spectral Libraries->Spectral Library Viewer and in the 
Spectral Library Input File window which appears, select the usgs_min.sli file 
and click OK.)    This is an earlier version of the on-line USGS spectral library which we 
have been using.

For simplicity we will use  two minerals we've seen before even if they may not be the 
best choice for matching this particular scene.  Click on Alunite (HS295.3B) and a 
Spectral Library Plots window will appear containing its spectrum.  Enlarge it to a 
reasonable size. Back in the Spectral Library Viewer window scroll to Kaolinite 
CM3 and click on it to display its spectrum.  Note that these spectra are at the full 
resolution of the library, but the filters for the Aster bands are wide enough that they 
would not resolve all the detail present.  We must average the spectra over the Aster 
bandpasses.   (Technically, we “convolve” the mineral spectrum with the spectrum of the 
filter's transmission,  just as in homework we convolved an image with a spatial filter 
kernel.)

8. Convolving the spectrum with filter transmission curves.
From the main ENVI menu select Spectral->Spectral Libraries->Spectral 
Library Resampling.  In the window which appears select the usgs_min.sli file and 
click OK.  In the Spectral Resampling Parameters window select Pre Defined 
Filter Functions. A sensor button will appear, probably reading the default Landsat 
TM4.  Right click on it and select Aster from the list which should appear.  (In some 
versions of ENVI you instead left click on the down-arrow at the right of the sensor 
button.)  In the lower part of the window specify an output file name like 
resampled_spectra (in your directory) and click OK.  .  ENVI will probably warn you 
that 5 of the 14 points are outside the wavelength range of the input spectrum.  It is just 
telling you that our spectrum doesn't extend out to the wavelength of the ASTER TIR 
filters.  That's OK since we will not be using those filters.  Just click OK to ignore the 
warning.  The resampled spectra, and also an entry for the aster filter transmissions, 
should appear in the Available Bands List.

To display the convolved spectra, go to the Spectral Library Plots window showing 
the existing plots and select File->Input Data->Spectral Library... and in the 
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window which opens select resampled spectra then click OK.   From the spectral list in 
the window which opens again click on Alunite (HS295.3B).  Scroll to Kaolinite 
CM3.  While holding CTRL down click on it to select it too, then click on OK.  In the plot 
window you should now see additional spectra,  consisting of only 9 points (at the 
ASTER band center wavelengths), with straight line segments between then.  To display 
the 9 spectral points more clearly, from the plot window menu select Edit->Data 
Parameters.  In the window which opens find the entry which corresponds to your 
convolved spectra and change the Symbol from None to Diamond.  You can also adjust 
line colors if you wish.  When done close the Data Parameters window.

Finally, to plot the transmission spectra of the ASTER filters, repeat the above procedure. 
From the Spectral Plots menu select File->Input Data->Spectral Library... 
and in the window which opens select aster.sli then click OK.  In the next window 
which opens select Bands 1 through 9 by holding CTRL down while clicking on them, 
then click OK.  The nine relevant Aster filters will be plotted. If you examine the plots 
carefully, you will see that the resampled mineral spectra do corresponds to the original 
spectra, averaged over the width of the ASTER filters.    Add a key to you plot with 
Options->Plot Key then save a copy of this plot for inclusion in your report.

When done go to the Available Bands List, right click resampled spectra, and click 
Close Selected File.  In the following work ENVI will automatically resample and 
convolve the spectra we select, based on the filter wavelength and bandwidth information 
stored in our data file.  The above exercise was just to see the relationship of the original 
spectra and the resampled ones.  In the following it's best not to confuse ENVI by giving 
it already resampled spectra.

Part III.  Spectral Unmixing using laboratory spectra

9. Unmixing the Como Bluff image with USGS spectra.
Lets see how successful Unmixing will be using a few spectral endmembers from the 
USGS library.   A brief look at the coarse nature of the convolved spectra should 
convince you that the results will not be very trustworthy.  With only 9 bands there are a 
large number of minerals which would easily be confused.  However the general class of 
minerals might be determined more reliably.  Once again, with hyperspectral data the 
results would be much better.

From the main ENVI menu select Classification->Endmember Collection and in the 
Classification Input File window which opens select 
aster_como_bluff_reflectance and click OK.  In the Endmember Collection window 
which then opens select Import->from Spectral library file and in the window 
which opens select usgs_min.sli then OK.  Select Alunite HS295.3B, scroll to 
Kaolinite CM3 then while holding CTRL down, select it, then click OK.   

Lets add one final component, a type of vegetation.  For that we will need to load the 
USGS vegetation library.  From the Endmember Collection window select 
Import->from Spectral library file. In the Spectral Library Input File 
window which appears click the OPEN> button at the bottom, then select Spectral 
Library... ..  A file selection box should open and you will either be in the main ENVI 
spectra directory, or in the usgs_min one you last used.  If the latter, move up to the main 
spectral directory.  You should see a veg_lib directory.  Navigate to it and select the 
usgs_veg.sli file.  Click OK in that window and the next higher level one.  An Input 
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Spectral Library window should appear giving a list of vegetation. From that list 
select Rabbitbrush and click OK.  That third spectrum should appear in the Endmembers 
list.

Finally, back in the Endmember Collection window, click Select All then from its 
menu select Algorithm->Matched Filtering then click Apply.  In the next window to 
appear pick reasonable output names (usgs_mix) for your statistics and output files and 
click OK.  The resulting MF Scores should appear in the Available Bands List.  

As you did above, display those MF scores in a new window linked to your original 
image.  Save copies of the three images for your report.  The match will probably be 
marginal, as we haven't put much work into choosing an appropriate set of end embers.  
Despite that, discuss in a few sentences whether the regions showing Alunite and 
Kaolinite corresponds at all to those formations which you might expect to  contain more 
clays and hydrated materials.  Is the modeling capturing the location of the vegetation?  

Finally, in the Endmembers Collection window click on the Plot button to display the 
spectra of the endmembers.  From the Plot window menu select Options->Plot Key to 
add a label key.  Use Edit->Data Parameters  to show symbols at the nine spectral 
points per plot.  You can also use Edit->Data Parameters or Edit->Plot Parameters 
to clean up your plot, for example changing unreadably light colors to something more 
useful, or changing the scaling.  When finished, save a copy for your report.

In summary your report should include

1)  A copy of the original RGB (Band 3, 2, 1) image for comparison with the other ones.

2)  A plot of the spectra from the preselected ROI's, with key.

3)  Eight images from the Linear Spectral Unmixing routine for the ROI spectra, plus 
a discussion of those results.

4) Eight images from the Matched Filtering routine for the ROI spectra, plus a 
discussion of those results.

4) The spectral plot showing the original Alunite and Kaolinite spectra, the ASTER 
filters, and the convolved spectra.

5)  Three images from the Matched Filtering routine for the USGS spectra, plus a 
discussion of those results

6)  The Endmember USGS spectra with key.

6


