
Remote Sensing 4113
Lab 7:  Unsupervised Classification

March 21, 2018

Part I  Introduction

Unsupervised classification is used to cluster pixels in a data set based on statistics only, 
without any user-defined training classes. Even so, the operator must specify certain 
parameters for the classification to produce good results.  ENVI provides two options for 
unsupervised classification of multi-spectral data: “K-Means” and “ISODATA”.  Today 
we will begin with K-Means because it requires less user input – but for that reason it 
may provide less than optimum results.

Suppose we have N pixels of data, with B different spectral bands for each pixel.   If this 
was a supervised classification scheme we might have ground-truth which told us the 
“correct” spectra for every different class.  Each of those “know type” spectra would plot 
as a point in this B dimensional space.  (If we had three bands we could plot band 1 as X, 
band 2 as Y, and band 3 as Z.)  To classify an unknown pixel we would just compute the 
distance (in B dimensions) from that pixel to each of the known type of spectra and 
assign that pixel to the type to which it was closest.  With an unsupervised classification 
scheme we don't know in advance the correct spectra of the different classes – we need to 
find that from the way the data is clustered.

From Sabins:  Remote Sensing

The K-Means classifier takes its name from the fact that it will divide the data into a 
specified number of classes (denoted by K) and take as the “correct” spectra the Mean 
(center point) of each class of points.  However finding the Means will be an iterative 
process because initially we can't know which pixels really belong to which classes.  
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To begin, the program starts with a random guess for the “center” of each of the K 
clusters, then iterates as follows.  It assigned each pixel to whichever cluster is closest, 
then once it has assigned all the pixels it recomputes the center of each cluster from the 
mean of all of the pixels currently in each cluster.  Once it has finished it begins a new 
iteration, reassigning pixels and recomputing means.  It keeps track of how many pixels 
are reassigned to a new cluster during an iteration, and also how much the cluster centers 
move.  If the number reassigned is above some specified threshold or a cluster center 
moves by more than a specified amount then the iteration repeats.  If not the 
classification is assumed to have “converged”.  In ENVI only the number-of-pixels test is 
used to check convergence.  ENVI does also offer one final option, related to the size of 
clusters.  If pixels are beyond a certain distance from a cluster center they can be left 
unassigned – however we will not use those limits.  The parameters we therefore need to 
specify are:

1)  which bands to use in the classification, 
2)  how many classes (K) to use, 
3a) the maximum percent of pixels which can be reassigned and
3b) the maximum number of iterations to allow before forcing the process 

to stop.  

Because K-Means simply accepts the number of classes we request, over or 
underestimating the actual number of distinct classes present in the data can produce 
unwanted results – either splitting regions which should really be in the same class, or 
grouping together pixels which are clearly different.  The simplest procedure (which 
we'll follow) is to repeat the classification using an increasing number of classes till one 
clearly has specified slightly too many classes, then use “post-classification tools” to 
combine the different classes which should not have been split.  (Although we won't use 
ISODATA today because of its complexity, it has an advantage in that it can 
automatically combine or split classes.)
 
There are two serious failure modes with K-Means which requires some understanding 
of the mathematics to recognize.   1)  It can get stuck at an “OK”, but not ideal 
classification.  2)It can have trouble recognizing unusually shaped clusters.
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Mathematics:

You can think of each pixel as forming a vector in a B dimensional space, where B is the 
number of bands used in the classification.  For B=2 each pixel can be plotted in a 2-D 
plane – for B=3 each pixel can be plotted in a 3-dimensional space.  The above figure 
from Sabins assumes B=3.  

Each pixel in effect forms a vector in this B dimensional space, with components (i1, i2, 
i3, ... iB).  The cluster center (or mean) is also specified by a vector:  (c1, c2, c3, ... cB).  In 
this B dimensional space the distance of each pixel from the cluster center is just

Sqrt[ (i1-c1)2 + (i2-c2)2 + (i3-c3)2 + ... (iB-cB)2].

The ultimate goal of K-Means is to find cluster centers and cluster assignments so as to 
minimize the sum of the squares of all of the distances of all pixels from their centers.  
Put another way, if C(x) is the center of the cluster to which a pixel is assigned then K-
Means is trying to minimize

SSdistance = ∑ [ x – C(x)]2

where the sum is over all pixels and all bands.  

However iterative procedures can get stuck at a “local” minimum in this function.  That 
is, no small readjustment of cluster centers and assignments is better – but there is no 
guarantee we have found the “global” minimum – that is the best of all possible choices.  
Restarting the system with a different initial guess and seeing if it produces a lower 
SSdistance or a vastly different classification, can be used to see if you really have found 
that global minimum.

Because K-Means treats all the bands identically, K-Means works best when the clusters 
are approximately spherical in n-dimensional space, and have similar sizes (variances).  
However if one band varies by an amount much larger than the others, then the clusters 
will be elliptical and K-Means can get confused. Often it will try to break a long skinny 
cluster up into a string of smaller spherical ones.  Ideally, before applying K-Means one 
should “rescale” the data so that clusters are spherical.  However, even when the 
instrumental characteristics are similar for the different bands – different targets can 
produce elliptical clusters.  For example desert scenes tend to have similar variances in 
the different bands, which tend to produce spherical clusters.  However forest scenes tend 
to have much more variance in some bands then others, producing elliptical clusters.  
Therefore one has to examine carefully the results of the classification process, and also, 
if possible, examine the statistics of the input data.  We'll ignore most of these 
complications in today's lab.
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Part II:  Specific Lab Instructions

We will use an ASTER image of Como Bluffs, just east of Medicine Bow.  For this 
exercise we will use only the Visible, Near-IR, and Short-Wavelength IR data, but not 
the Thermal IR data.  Because ENVI requires all pixels be the same size, the lower-
resolution SWIR data have been resampled to have the same 15-m resolution as the 
VNIR data.  Use the Como Bluffs image file contained in the lab_08_data.zip file on 
the class website.  As usual, download it and unzip it to a directory you create within your 
local c:\tmp .  dAgain, be sure to save any files you want to retain on your H: drive.

The steps below outline what you should do in this lab.  Specific ENVI directions on 
how to use the K-Means classifier and also the required annotation functions is given on 
the last page.   Refer to them and also the ENVI Help menu item for detailed 
instructions.

1) Open the image file and display bands 3,2,1 as an RGB image (in “Display 1”), to use as 
a guide.  Note that ASTER does not have a Blue band, so these will be NIR, Red, and 
Green, creating an “IR Color Image.”  If possible enlarge the main display enough that 
the Scroll window disappears.  It may take a couple tries to make this happen.  Save a 
jpg copy of the full image for inclusion in your lab report.

2) Construct 3 different K-means classifications using the Aster sub-scene provided  Start 
with 5 classes, checking your classification as explained in the instructions below.   
Include copies of the classification images in your report.  You will probably decide that 
5 is too few and your eye can distinguish regions which are mistakenly being classified 
the same.  Describe in a few sentences what problems you see with the classification.  
You might want to include a jpg copy of the image showing just the problem classes, as 
well as the full classification one.  Next try 10 classes, include a copy of it and discuss 
any improvements or remaining problems, finally try a version with 15 classes, and again 
include a copy and describe how well it works.  In the end you will probably decide that 
10 is the best number of classes to request.  (NOTE:  When requesting 15 classes you 
may want to set the tolerance (threshold) to 5% pixels to keep the program from running 
for a long time.  You can “cancel” a classification if it is taking too long.)

3) Return to the 10 classes result obtained above for the following.  Select it as the 
classification overlay for your Display #1 Color-Infrared Image.  It will most likely have 
failed to split some regions your eye can differentiate, but will also have split some 
regions that are so highly intertwined you would like to see them combined.  For example 
because K-Means uses intensities rather than band ratios it may break up a given unit into 
slopes facing towards the sun (brighter) and those facing away from the sun (darker), but 
a geologist would want them classified the same.  We will use the “Post Classification 
Tools” to fix that.  Go through your 10 classes and decide on at least two “excessive” 
classes you want to combine with other classes. Write the numbers of the classes down in 
your report.  Use the “Post Classification” instructions given below to combine those 
classes.  Save the result as a new file.
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4) Using the computer instructions below produce a final classified image with a 
classification key in the corner.  The class names should be more useful ones than “Class 
1” ... for example: “Vegetation + Water”, “Red Beds”, Rock Unit #2”, etc.  Save that 
image including the classification key as a jpg file for inclusion in your report.   Compare 
your results to the “Wyoming Geological Map” by Love and Christiansen (1985) 
included at the end of the lab.  You may also want to compare it to the older but higher 
resolution map from Robert Dunbar's 1942 thesis, which is also attached.  However when 
possible use the more modern names for the units, from Love and Christiansen.  Discuss 
in a few paragraphs the success of the classification and any problems with confusion 
between different types of terrain.  In particular, address the following points.  

Discuss the expected “apparent” color of red rocks in your “IR Color Image” which 
shows  as RGB bands (#3,#2,#1).  The Chugwater and Goose Egg formation are Triassic/
Permian red beds.  Do you see a class which roughly corresponds to them?

The unit labeled “Kmt” (Mowry and Thermopolis Shales) should be evident as one of 
your classes.  The exposure at the western nose of the anticline should occur near the 
highway.  Do you see this class?  In places does K-Means confuse it with another type of 
material?

What other group of rock units is at least crudely recognized by K-Means?

What other non-rock classes are detected?  Are these every confused with rocks?

Summary:  Your report should contain:

1. A copy of the original color-IR image of the Como Bluffs region

2. A set of classification images using 5, 10, and 15 classes, as well as a brief discussion of 
how well each classification has worked.  You may want to include additional images 
showing just the problem classification layers superposed on the original color-IR image.

3. A  list of what classes you decided to combine from the 10-class result, and why you 
decided to combine those particular classes..

4. The revised classification image, including a superposed key giving classes with 
reasonable names and colors.

5. A paragraph or two discussing the quality of the final classification, the relationship to 
the geological map, and any problems with your classification.  In particular note 
dissimilar pixels it was unable to split, and similar pixels it mistakenly split.
Be sure to describe:
a)What other group of rock units is at least crudely recognized by K-Means?
b)What other non-rock classes are detected and are these ever confused with rocks?
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Part III:  Computer Procedures

Procedure for K-Means Classification:

1. From the main ENVI menu select Classification->Unsupervised->K-Means.

2. When the Classification Input File dialog appears, select the desired input file.  Leave 
Spatial Subset at the default Full Scene, Spectral Subset at the default 9/9 
Bands, and Select Mask Band at the default None Selected.  (You could choose just 
to use a subset of the available bands.)  Click OK.  That will bring up the K-Means 
Parameters window.
a.   Select the desired Number of Classes.
b.   For this exercise select a pixel  Change Threshold %  of 1%.
c.  Set the Maximum Iterations to 50 (which should be more than enough for
     “convergence”).
d.  Leave the optional distance thresholds (Max. Stdev From Mean and 
     Max. Dist. Error)  blank.
e.  Choose an output file in your directory.  (You could output to memory for testing.)

3. Click OK to start the K-Means classification. Statistics are calculated for each band of the 
image, and a status displays the progress of the operation. The status bar cycles from 0 to 
100% for each iteration of the classifier.

4. After classification ends the results will appear as a “band” in the Available Bands 
List.  On the Display #1 color-infrared image's menu click Overlay-
>Classification, and select the classification file from the file or memory menu then 
click OK.  A key will appear with an on/off button for each of the K different classes you 
have created, plus an “Unclassified” category.  Turning the buttons on or off will overlay 
the classification values on your display, allowing you to judge how well the automated 
classification has done.  Besides stepping through overlays of the different classes, you 
may also want to load different bands into Display One to understand what spectral 
characteristics the classification program has used.  (RGB = #9, #4, #1 is one useful 
combination.)  If your eye can detect clear differences in the image which the classifier 
has not recognized, you may want to specify more classes.  If it is splitting up regions 
which look identical (in all the relevant bands) then you may want to specify fewer 
classes.  To dismiss the classification overlay, close the classification key window.

Note:  To compare images you can also load your classification results as a Gray Scale 
image on a New Display – then use the Tools->Link->Link Displays menu of that 
new display to link it to the original color-infrared image, or to another classification 
image.  Holding down the left mouse button within one image causes the other one to 
momentarily appear.  
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Procedure for post-classification combination of classes

From the main ENVI menu select 
Classification->Post Classification->Combine Classes then when the 
Input file window appears, select the correct classification file.  For the following 
example, assume you wanted to merge classes 1 and 2 into a single class 1.  First select 1 
as the input class, select 1 as the output class, then click Add Combination.  Next select 2 
as the input class, 1 as the output class, then again click Add Combination.  If you 
wanted to combine other groups, you could also enter them here.  Finally, once you have 
entered all the “input” to “output” mappings you need, click OK.  An output file box will 
appear.  Choose a name for the output file.  By default the system will not eliminate the 
discarded classes – it will simply leaving them empty.  It is usually simpler if you do 
eliminate those empty classes.  Change that option to Yes then click OK.   The file will be 
created and will appear in the available bands list.  To display the new classification close 
the old classification key window then use Overlay->Classifications and select the 
new one.

Procedure for renaming and re-coloring classes.

In the class key window – probably titled #1 Interactive Class Tool, click 
Options->Edit Class Names/Colors then make the modifications to the names and 
colors.  Ideally you should use similar colors for similar types of features.  When done 
use File->Save Changes to File to save the changes you have made.  Keep a list of 
your final names and color choices.

Procedure for adding a classification key to your image.

1) Open a new display showing your classification image if you haven't already done this, 
and enlarge it enough to make the Scroll window disappear.  On this display's menu 
select Overlay->Annotation then from the menu of the Annotation Window which will 
appear select Object->Rectangle.  Set Fill to Solid.  Draw a white rectangle on the 
classification image, in an “unimportant” corner, by “dragging” with the left mouse 
button.  Click the right mouse button when finished.  This will give you a blank area to 
place a key

2) Select Object->Map Key in the annotation window.  Select black color so the characters 
stand out against the white rectangle.  Left click on the map to place the key – right click 
to make it “permanent”.  You may have to manually change key colors and names in 
your key to match the image.

3) In the “Annotation Window” menu select File->Save Annotation then enter a file in 
which to save this. The annotation can then be reapplied to the window later by going to 
the Display Window's menu, selecting Overlay->Annotation, then when the 
“Annotation Window” appears, selecting File->Restore Annotation from the menu.
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Wyoming Geological Map  by Love and Christiansen (1985)

 
Partial Legend of units
       Qa     Quaternary  alluvium, colluviums

       Qt      Quaternary  gravel, pediment, and fan deposits

     Twb   Wagon Bed Formation
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Older but more detailed map from Robert Dunbar's  MS. Thesis  1942
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