
Geology/Geography 4113
 Remote Sensing

Lab 06:  AVIRIS Spectra of Goldfield, NV
March 7, 2018

We will use the image processing package ENVI to examine AVIRIS hyperspectral data of the 
Goldfield, NV mining area.  First we will examine individual spectra, then we will use band ratio images 
and band depth images to identify individual hydrothermal alteration minerals which outline the possible 
location of ore deposits.  The AVIRIS instrument was flown an a NASA ER2 (U2) aircraft.

As in Lab 4 and 5, you will prepare an on-line (Word) illustrated report of approximately 5 pages 
summarizing your results from the various image processing operations explained below.   When your 
report is complete email the lastname_lab_06.doc  file to Taylor at <tsulli12@uwyo.edu>. 

The main data files for this exercise can be found on the class websize as lab_06_data.zip.  As before, 
you'll want to download the zip file and extract it.  However because this hyperspectral data file is so 
large (160MB zipped, over 250MB once extracted), don't place it on your home or H: drive. If everyone 
tries to access a file that large from ENVI over the network, the network will slow to a crawl.  Instead 
place the zip file and then the extracted data files in a  folder within the local c:/temp directory on your 
machine.  However be sure to save any files you will need later on your network HomeDrive, as files on C:/
temp are deleted when you logoff.

1. Start ENVI Classic on your machine.

2. Click on File>Open Image File> and navigate to aviris_goldfield_nevada in the file dialog.  
You should then see an available band list which includes 224 bands, ranging from 0.37 to 2.51 
microns.  The numbers in parentheses are wavelengths, in microns.  

3. In the Available Bands List window, select the RGB Color option, specify bands #190, #56, and 
#4 for the RGB channels, then click Load Band to display it.  Drag the corner of the main image 
window to enlarge it.  Once you make it as large as the full Scroll  image, Scroll will disappear 
as it is no longer needed.  Save a copy of the image to include in your report.  As we'll see later these 
specific bands were chosen to correspond to different alteration mineral absorptions, so this display 
shows a great diversity of colors.  As described in Sabins on pg. 366-371 and 378-382, the complex 
circular structure at the middle right is the location of an small caldera and ring-fracture system 
emplaced during the Oligocene through Miocene.  Hydrothermal fluids circulating along the ring 
fractures and in the center altered the preexisting minerals and deposited quartz, gold, and other 
materials.  The alteration products consist primarily of clays or sulfates, and they can be used to 
provide an indication of where ore bodies might be found.  (In the following, to keep the names 
simple I’ll refer to these collectively as “clays” even though one of the minerals we’ll be 
investigating, alunite, is really a sulfate.  Because it is a hydrated sulfate it has O-H bands similar to 
those found in clay.)

4. Click on the cyan region near the middle of the main image window to position the cursor, then from 
the main image window choose Tools->Profiles->Z Profile (Spectrum) and a new window 
will open showing the spectrum.  Enlarge the window to a reasonable size by dragging on one 
corner.  Next, to specify more reasonable plot parameters, do the following.  From the plot window 
menu select Options and make sure Auto Scale Y Axis option is off.  (If it is on there will be a 
check before the menu item.  Click on it to toggle it off.)  This will keep the system from rescaling 
the plot every time we display the spectrum of another pixel, which makes it easier to compare 
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spectra. Next, again from the plot window menu, select Edit->Plot Parameters.  In the window 
that opens select the Y-Axis using the check circles about ¼ of the way down, then specify the 
Range from 0 to 1 and click Apply.  Select the X-Axis using the buttons.  The Tick Marks should 
already be set as 0.5 to 2.5 inc 0.5.  Change the Minor Ticks to 4 so the tics will be located at 
0.5, 0.6, 0.7, etc. instead of the much less useful default of 0.500, 0.625, 0.750, etc.  When done 
click Apply, then close this plot parameter window using the X button at the top left.

Your spectrum should now look something like the following.  Save a copy to include in your 
report.  The vertical blue, green and red lines indicate which wavelengths are being displayed in 
your image.  The noisy regions near 1.4 and 1.9 microns correspond to strong atmospheric 
absorptions.  This spectrum has been corrected for atmospheric absorption, but in these regions the 
signal is so low the correction essentially results in zero divided by zero, giving high noise.  You 
need to avoid those noisy bands in the analysis.
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Sabins  Figures 11-08A and 11-17

5. Move around your image, clicking on different colored regions, and observe the spectrum change.  
Examine a number of spectra around the various different alteration regions indicated by the 
different colors.   Try to locate in the spectrum regions where various different diagnostic 
absorptions appear. How do those compare to the absorptions indicated in Sabins Figures 11-8A and 
11-17?  Try the following areas, and look for the absorption patterns listed.  Explore the image to see 
if you find any other spectrally distinct regions.

Cyan     area   in middle of image:  It should show an absorption feature near 2.32 microns, and a two-
minimum absorption in the 2.15—2.20 microns region, with the shorter wavelength dip being deeper 
– more-or-less matching the spectrum of alunite in figure 11-17.

White     area   (surrounded by cyan), NE of Goldfield.  It should show no feature at 2.32 microns, but a 
two-minimum absorption in the 2.17 – 2.22 micron range with the longer wavelength deep being 
deeper, more-or-less matching kaolinite in figure 11-17.  As you move around also notice how the 
0.9 micron absorption changes.

Salmon     colored areas  , slightly to SE of the center of the caldera.

Blue     areas  , slightly S of the above salmon areas.  (These form a very incomplete ring around the 
caldera.)

Save and include in your report at least four distinctly different spectra from the alteration region.  
To save spectra you can either use the  Alt-PrintScr or Alt-F14 keys to copy the active window to 
the clipboard, then to your report, or you can use the File->Save Plot As->Image File, specify 
jpg format, then specify a file in your directory.  When specifying names it is good to add _spct to 
the end to avoid conflicts with similarly named files you might be generating later.
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Briefly (in a few sentences) discuss their differences, and any similarities you see to mineral spectra 
in Figures 11-8A and 11-17.  Note within the 16m pixels we will almost always have more than one 
mineral, so we won't get pure spectra of any specific mineral.

6. Next we want to use band ratio images or slightly more complex “band depth images” to locate the 
alteration minerals in general, and then locate the specific types kaolinite, alunite, and illite.  First we 
will produce a general map of the alteration mineral (“clay”) locations.  Examining the spectra in 
Figure 11-8A, all are dark at 2.4572 microns (band #219) but bright at 1.1536 microns (Band #84).  
Therefore a Band 84 / Band 219 ratio image will highlight these locations.  From the main ENVI 
menu select Transform->Band Ratios then in the window which opens  select band #84 as the 
numerator and #219 as the denominator, click Enter Pair then OK.  In the next window which 
opens, choose a file, select your working c:\temp directory, name the file clay, then click OK  first 
in the chose window then again in the band ratios one.  (Note:  After you have selected the directory 
once for an output file, for later output files you should be able to skip choose and simply specify 
the name.)  The file should appear in your Available Bands window.  Display it in a new window.  
Enlarge that window so the scroll window disappears, and you can compare it directly to your 
original data window. You should see clays located in a circle along the ring fractures, and also in 
what was the resurgent center of the caldera. Save a copy in jpg format for inclusion in your report.  
To do this, from the Image menu use  File>Save Image as->Image file then select a JPG 
format.  The system will insist on a name different that clay, to avoid conflicts with the above 
binary image file.  Use something like clay_img.  

7. Examine the spectra in Sabins Figure 11-8A.  We want to find a signature of kaolinite which will be 
different than all the other clays.  Kaolinite is the only one of the clays shown which stays high in 
the 1.9--2.0 micron region.  Therefore the ratio of the bands 1.9586 micron (#169) / 2.2086 
micron(#194) will be high only for this clay.  Repeat the instructions in step 6, but for these two 
bands, and save the result in a file kaolinite.  Display this in yet another window and enlarge it till 
the scroll window disappears.  Also save a jpg copy of the image for inclusion in your report.  
Compare it and the general clay image.  How well do they agree, that is, are there clays other than 
kaolinite present?  If so, point out some locations where this occurs.

8. To locate alunite we can use the absorption feature at 2.32 microns in Figure 11-17, as it is present 
only in this alteration mineral.  However to help isolate this mineral from others which do have more 
subtle spectral structure here, if not clear absorptions, we will use a “band depth image” rather than a 
simple band ratio image.  Band depth images are explained in the appendix at the end.  

For alunite the appropriate bands and wavelengths for the left continuum, the band center, and the 
right continuum, are #202, #206, and #210, or 2.2883, 2.3281, and 2.3679 microns.  To compute the 
band depth map from the main ENVI window select Basic Tools->Band Math.  In the “Enter an 
expression” field enter 1-B2/((B1+B3)/2.) then click Add to List, select the expression which 
now appears in the top part of the window, then click OK.  The Variables to Band Pairings 
window will appear.  You need to tell it that B1 is Band #202  by first clicking on B1 in the 
Variables field then clicking on Band #202 in the Available Band List field.  Repeat this for 
B2=Band #206 and B3=Band#210.  Next, in the bottom of the window tell it you want to output the 
result to a file (rather than memory) and choose a file alunite in your working directory, then click 
OK.  After a few seconds this new Band Depth Image will appear in the available band list.  Load it 
as gray scale into yet another new display, enlarge it, then save it for your report.  Compare it to the 
kaolinite image.  There will be places where both alunite and kaolinite are present, but other regions 
where only one is found.  Discuss in a few sentences what similarities and differences to you see.
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9. The final clay to map is illite.  Unfortunately it does not have any features in regions where other 
clays will not contribute.   Its most diagnostic feature is the absorption at 2.22 microns, but we will 
have some confusion with kaolinite and also alunite.  First, compute another Band Depth Map using 
the steps above, but enter the expression as 1-B5/((B4+B6)/2.) and assign B4= Band #189, 
B5=Band #196, B6=Band #203, (2.1587,  2.2285, and 2.2983 microns).  Save the ratio as illite. 
Display it in yet another new window as gray scale, enlarge it, save a jpg copy, and include it in your 
report.  You will notice some bright areas which do correspond to illite, but there will also be dark 
areas caused by confusion with the other clays.  Those clays can depress one of the “continuum” 
points so much as to produce an artificial “negative” band. 

10. Because of the interference from other clays, for illite we will simply try to determine a present/not-
present map by seeing if our band depth map is above some threshold. From the illite image menu 
select Tools->Cursor Location/Value to display the data values under the cursor.  Determine a 
typical data value well away from the hydrothermally altered area.  If clays are not present it should 
be close to zero.   Enter that in your report as “Background”.  Next determine the maximum band 
depth values in the altered areas, and record those as “Illite Maximum”.  Those presumably are the 
areas with the most illite.  Pick a threshold value half way between these levels and record it in your 
report as “Threshold”.  We'll use that in the next step.  From the main ENVI menu once again select 
Basic Tools->Band Math.  Enter the expression B7 GT xxx where xxx is your threshold.  This 
expression will return 1 if the band you specify as B7 is greater than the threshold, and 0 otherwise.   
Tell the system B7 is the illite band depth map you just created, and save the result of this operation 
as the file illite_present.  Display this as one more gray scale image and save it and include it in 
your report.

11. Finally, we will create a combination color image showing our three clay locations.  From the 
Available Bands List window create a new RGB image, with R=kaolinite, G=alunite, and 
B=illite_present.  Save the resulting image for your report.

12. Compare your RGB composite image to Sabins Plate 21 F and your three individual clay images to 
Sabins Figure 11-18 A,B,C.  In those figures more complicated analysis techniques were used to 
estimate clay abundances, using a slightly earlier AVIRIS data set.  Discuss in a paragraph or two 
how well the results of the simple spectral methods we used compare to those results.  Note the 
absolute colors will likely be different, with the one you generated being “greener”.  Don't worry 
about that as the difference is partly due to the display “stretch” being used.  Concentrate on the 
locations of the different components.

13. Go back to the spectra you saved in step 5 and mark on them the bands and features we have used in 
this analysis.  We picked these “spectral endmembers” by eye, with some hints on what color 
regions to examine.  Discuss in a few sentences how well the features we chose to use match 
features evident in the laboratory spectra of Sabins Figures 11-08A and 11-17.   Looking at the 
spectra and the component images, discuss whether we have regions purely made of one mineral, or 
whether all of these regions show mixtures of minerals, with perhaps one major component?
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When finished your report should contain:

• An overview image of the area
• The spectrum of the cyan region from step 4.
• Spectra of other spectrally distinct regions from step 5, and a comparison to Sabins Fig. 11-8A and 

11.7A, from step 5.  (One of the four can be the cyan region above.)
• A copy of the "clay" image from step 6
• A copy of the "kaolinite" image from step 7, and a discussion of the differences between it and the 

"clay" image.
• A copy of the "alunite" image from step 8, and a discussion of the differences between it and the 

kaolinite image.
• A copy of the "illite" gray scale image from step 9.
• A copy of the "illite present" image from step 10.
• A copy of the RGB kaolinite, alunite, illite_present image from step 11 and a discussion of how it 

compares to Sabins Plate 21F and how the three individual clay images compare to Sabins 11-18 A,B,C.
• A final marked copy of the spectrum from step 5, showing the features used, along with a discussion of 

how well those features match features evident in Sabins Fig. 11-08A and 11-17 and how well we detect 
individual minerals or combined mixtures of minerals.
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Appendix:  Band Depth Images

In a band depth image we use information from both sides of the absorption feature.  We fit a straight 
line between the “continuum” on either side of the band and interpolate to find the intensity we would 
expect at the wavelength of the center of the band, if that band were not present.  Call that IC.  We then 
compute the Band Depth = (IC-I)/IC = 1-I/IC.   This will be 0 if there is no band (so I=Ic) but will be 1 if 
the band goes all the way to zero intensity (I=0).  The bigger the band depth, the deeper the band.  If 
other minerals are present which just produce a constant slope over this region, we will still get zero for 
the band depth.  For example we will have little confusion with kaolinite.  However because illite does 
have more complicated structure here, we may have some confusion with that mineral.  (In later labs 
we'll use better techniques for distinguishing different minerals.)

To make the algebra easy we will interpolate between two continuum points equally spaced on either 
side of the band, so if they are labeled IA and IB, IC = (IA+IB)/2.  If they were not equally spaced we would 
need to find the equation of the line which passed through them and solve for the value of IC at the band-
center wavelength.

If the continuum points IA and IB are not located symmetrically around the band, then the formula for Ic 
becomes more complicated.  We find the equation of the line through (A, IA), (B, IB) then use it to find 
the expected intensity IC at , the band center wavelength.

                                      IC= I A+
I B− I A
λB− λ A

( λ− λ A )
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