
Geology/Geography 4113
 Remote Sensing

Lab 05:  Aster Thermal Data
Feb. 28, 2018

We will use the image processing package ENVI to examine thermal infrared data of lava flows at 
Kilauea, HI.  As part of this exercise we will also learn new tools included in the ENVI package, 
including those which calibrate Aster data, and which produce spatial profiles.

As in Lab 4, you will prepare an on-line (Word) illustrated report of approximately 3 pages summarizing 
your results from the various image processing operations explained below.   As you did last week, 
create a new directory (I'll call it lab_05)  within the c:\temp directory, and keep all original data files 
within that directory.  That directory will be erased when you log off, so copy any files you really want 
to keep to your network Home Drive (H:).  When your report is complete copy the 
lastname_lab_05.doc  file to the Homework Drop directory at 
\\uw-bulk.uwyo.edu\geobulk$\Commons\Howell share\Homework_4113_Drop
and notify the lab TA that it is available.  

The main data file for this exercise can be found on the class website.  Download lab_05_data.zip to 
your machine and unzip it, which should produce a file kilauea_aster_2001_01_01.hdf and two 
backup files which we will probably not need to use.  (They were needed with an earlier version of 
ENVI which has a bug.)

1. Start ENVI Classic on your machine 

2. We need to tell ENVI to read in the raw data from the file, without applying the automatic 
calibration it would ordinarily employ.  To do this from the MAIN WINDOW MENU select  
File->Preferences and select the Miscellaneous tab. Change the option marked Auto-Correct-
Aster/MODIS to NO, then click OK.   It will bring up a message box asking you whether you want to 
save that preference to a file (for the next time ENVI is started).  Select NO so that the next time you 
start ENVI it will revert to its normal Auto-Correct = Yes state.

3. Click on File>Open Image File>kilauea_aster_2001_01_01.hdf.  You should then see an 
available band list which includes the Short Wavelength Infrared (SWIR) bands 4 – 9 and the 
Thermal infrared (TIR) bands 10-14.  The numbers in parentheses are wavelengths, in microns.  The 
two groups are listed separately since they have different spatial resolution: 30m for the SWIR data 
and 90m for the TIR data.  Because of the different resolution you won't be able to display 
composite images using bands from the different groups – unless we “resample” the data in one set 
to match the resolution of the other.

4. Select Gray Scale and select band 12 (9.0750 m) then click Load Band to display it.  In the 
Scroll image window drag the red box to the upper right, so the Image window displays the upper 
right corner of the available data.  Using the default display parameters you should see something 
like the following image.  This is a nighttime image so the ocean is warmer than the land (since it 
has a higher thermal inertia.)  The clouds are colder than either the ocean or the typical land.  In this 
band old lava flows are visible as dark patterns running from the rift zone, down the cliffs or “pali” 
to the sea.  The active flow is bright because it is still very warm.  Experiment with different 
enhancement choices – in particular try Image Linear.



5. With Image Linear enhancement chosen, move the red box within the Image window over the 
active flow, so the active flow is visible in the zoom box.  You may want to click the - or + symbol 
within the zoom box to adjust the size of the zoom to include most of the active flow.  Use a zoom 
large enough that you can clearly see the individual pixel squares.

6. Select Tools->Cursor Location/Value from the menu above the Image window.  A new window 
should appear.  It lists the pixel number (x,y) where (0,0) is the upper left corner pixel in the full 
(scroll) image.  It lists the DISPLAYED RGB channel values (0-255), which will all be the same in this 
gray display.  For “geo-referenced” data like this it lists the UTM zone and coordinates (in meters) 
and the latitude and longitude.  Finally, and most importantly for now, it lists the original data value 
for this pixel.  Since Aster TIR returns 12 bits of data the data value can range from 0 to 4095 
(=212-1).  Any pixels which show 4095 are “saturated”:  the actual brightness is greater than or equal 
to this value.  Explore the lava flow and you will see that the hottest regions of the lava flow do 
saturate this channel (and the other TIR ones).  We will see later that in most cases they are not hot 
enough to saturate the SWIR channels.

6. To obtain a graphical view of the pixel-to-pixel variations select Tools->Profiles->X Profile. 
This will display a “crosshair” in the Image window and will open up a new window which displays 
a plot of data number vs. x pixel number in a new window, for the pixels along the image window's 
horizontal crosshair..  Obtain at least one profile cutting across the active flows and another profile 
cutting across the old flows and the ocean. Save these profiles using the 
Files->Save plot as->Image file menu on the profile window. Select JPEG as the type and 
choose a file name, located within your Home Drive folder.  When done close the profile window 
with File->Cancel or click the X box at its upper right.  You should also save in JPEG format a 
copy of the image itself, so you can mark on it where your profiles are located.



7. Try loading the other TIR bands into this same gray scale Display 1 and note how most features 
stay more-or-less constant, but the old flows are only prominent in band 12.  They are much less 
obvious in all the other bands.  To test this select RGB then select bands 14, 12, and 10 for the 
R,G,B channels and click Load RGB.  Using the default “enhancement” what color are the old 
flows?  Save a copy of this image to use in your report.  Explain in a sentence or two why the flows 
have this apparent color, given that the 14, 12, and 10 bands have the individual appearance they do.  
Next, suggest in a few sentences why the #12 band might be different than the #14 and #10 ones.  
For example, is this a temperature effect or something else?

8. While the SWIR bands are normally used to measure reflected sunlight, these Aster images were 
taken at night and most of the image will just show low-level noise.  However the hotter parts of the 
lava flow will actually emit thermal radiation at these intermediate wavelengths.

Open a second set of display windows by clicking Display #1->New Display on the Available 
Bands List window. Select RGB then choose Bands 9, 6, and 4  (2.400, 2.209, and 1.656 m) for 
R, G, B, then click Load RGB.  Most of the scroll window will just show noise but one part should 
show a bright patch.  Move the red selection box over it, then on the Image window choose 
Enhance->Image Linear to adjust the display.  With this choice of display you should just see a 
pattern of bright spots but probably not a continuous flow.  Try to match the overall pattern here to 
that in the thermal (Display #1) image.  To confirm that these patterns do match use the Cursor 
location values.  Find some prominent feature which you think you can match in both TIR and 
SWIR displays, and record the UTM coordinates of that feature for both displays.  (Note the Cursor 
Location window tells you which display your cursor is over.)  Save copies of the SWIR and TIR 
images in JPEG format to include in your report when discussing this result and that of the following 
step.  You may want to enlarge the zoom window somewhat, then use Enhance->Zoom-Square 
Root to adjust the display.  Instead of saving the Image window, you could save the Zoom window.

9. Using the UTM numbers, estimate overall length of the active flow in the TIR image and the size of 
the bright regions seen in the SWIR image.  Also check see if the UTM numbers change by the 
expected amount as you move from pixel to pixel (i.e. check the resolution of both the SWIR and 
TIR images.)

10. Use the cursor to scan over the SWIR image of the flow field (try using the zoom window) and 
record the highest data numbers present in this channel when the pixels are saturated.  How many 
bits are used  recording the SWIR results?  Is it also 12 bits like the TIR channels?  With n bits the 
highest data number will be 2n-1.

11. Calibration of TIR data.  The instrument records 12 bits of data (data numbers 0 - 4095) for each 
TIR pixel, but we must multiply these data numbers by calibration factors to convert them to useful 
intensity values.  Once done those intensity values can be used (with the Planck formula) to estimate 
temperature.  While we could look up calibration values in the Aster documents and use the 
Band Math tools to apply them, ENVI has built in the appropriate calibration functions.

First, close the current file using the command in the Available Bands List window menu:  
File->Close All Files.  (Be sure to close the files – closing the window displaying them isn't 
enough.)  Repeat the instructions listed in step 2 but change the Auto-Correct-Aster/MODIS flag to 
YES, then read in the data file again as described in step 3.  This time ENVI will automatically 
calibrate the data as it is read in.  Once the new calibrated bands appear in the Available Bands 
List window, load bands 14, 12, and 10 as RGB.  As necessary move the red boxes to display the 
active flow in the image and zoom windows, and select Enhance-> Image Linear.



12. Recording calibrated intensities for various locations
Use the cursor location value window to record the data value for these three channels in four 
locations:  

1)  The ocean;
2)  a non-active part of the flow;
3)  an active but not saturated part of the flow,  and
4)  a saturated pixel.

The numbers reported will be in units of Watts m-2 μm-1 steradian-1

One “typical” value is given to test whether your results are reasonable.

Wavelength: 11.318   9.075 8.291 m

Ocean: _______    8.580   ________

Inactive flow: _______ ________ ________

Active flow: _______ ________ ________

Saturated: _______ ________ ________

13.  Converting intensities to temperatures.  
In the following we will assume emissivity ε = 1, i.e. we assume the surfaces emit like blackbodies.  
In reality ε will be slightly less than 1.
The Planck formula which gives the intensity of emitted light at a given wavelength for a given 
temperature surface is 

I=B( λ ,T )=
C1 λ

−5

exp (C2 /( λ T ))−1

where C1 and C2 are constants given below.  If we invert that equation to solve for temperature, 
given wavelength λ and observed intensity I, we obtain

T=
C2

λ ln (C1 /(I λ
5)+ 1)

When we use units of:
I:     Watts m-2 μm-1 steradian-1, 
:    m  (i.e. microns)
T:    K  (i.e. Kelvin)
then 

C1=  1.191 x 108 W m-2 μm-1 str-1 μm5

C2 = 14388. K μm

As a test of the above formula, if you input I = 28.175 Watts m-2 μm-1 steradian-1 at a wavelength of 
 = 8.291 m, you should obtain T = 370.0 K.

Using the above formula convert the four measured intensities at 11.318 microns into temperatures, 
and discuss briefly the results.  To see if you get a similar result from the other wavelengths, also 



convert your 8.291 m intensity of the inactive flow into a temperature and compare it to the 
11.318 m result.  (So you need 4 temperatures from 11.318 m, and 1 temperature from 8.291 m.)

Wavelength:                     11.318                     8.291     m  

Ocean: ______

Inactive flow: ______ ________

Active flow: ______

Saturated: ______

Summary of the required elements of the report:
Prepare a 2 or 3 page report (including profiles and images) including the answers to the above 
questions.  Your report should include:

The lab title and number, and the date you completed it.

Your name (and your lab partner), and the computer you used.

Your two profiles from step 6, along with a copy of the image indicating where the profiles are located 
on that image.  Mark or describe in words what parts of the profile correspond to what features in the 
image.

Your description of the displayed color of the old flows in step 7, along with an explanation of why it is 
displayed in that color and why the intensity in band #12 might be different than in #14 or #10.

An explanation of how you confirmed the SWIR hot spots match the LWIR flow location in step 9 – 
including UTM coordinates of any matched locations.  Include the relevant SWIR and TIR images in 
your report – for this step and the following.

An estimate of the length of the active flow in the TIR image and the size of the bright SWIR regions 
from step 9, plus your estimate of the pixel sizes in meters.

Your record of the highest data numbers seen in the “raw” SWIR images in step 10, and the number of 
bits used in recording those images.

Your table of calibrated intensities for four locations and three bands, in step 11.

Your table of temperature estimates for the four locations in step 12, and a discussion of the 
temperatures you obtained.


